XBMC 12 Frodo – Beta 3

Posted By: Nathan Betzen on Dec 08, 2012 in Site News

Hot on the heels of Beta 2, we are excited to release Beta 3. This release includes a number of fixes as we work to resolve issues that have cropped up since Beta 2 and also attempt to isolate some issues that still exist. For a quick run down of some of the big ones:

  • Users of Android 4.2 should now be able to install and run XBMC for Android.
  • The upgrade path of Windows users has been a little tricky.  Users may upgrade to beta and discover the audio no longer works. This is due to a bit of trickiness with the AudioEngine upgrade. For Audiophiles to get the most out of AE, we recommend that you check out the AE Wiki entry.
  • For those Windows users who find themselves without sound, the simple fix is to go to System->system->Audio Output and switch WASAPI to DirectSound. Users doing a clean install of XBMC for Windows Beta 3 should have no problem.
  • PVR Addons have been included with XBMC for Windows, matching up with most other ports.
  • We are still only partially complete on translations for numerous languages, including Romanian, Japanese, Estonian, Bosnian, Serbian, Hindi, and more. If you feel comfortable with one of these languages, but don’t know how to help, feel free to visit our forum thread that explains how to help translate XBMC using TransifexUPDATE: Additionally, Transifex is used for translations for addons and skins, so you are always welcome to go back to a more complete language and help with any unfinished addons.

Finally, we’ve begun compiling a list of some of the more frequently asked questions about the transition from XBMC 11 Eden to XBMC 12 Frodo.  If you haven’t made the switch yet, or just want to read about what other people are running into, please visit the XBMC 12 Frodo FAQ.

Conclusion

But enough of all that. Now is the time to get to downloading.

Let us know what you think of the changes in the comments below, or, if you like, via the donation button at the top of the page.

And if you have any problems, don’t hesitate to post about them in our forums and report verified bugs in Trac.

Share on reddit
Share on StumbleUpon


Discussion - 79 Comments

  • NineT9 Dec 08, 2012 

    I’m more excited for this Frodo then the one in The Hobbit in a week

  • purewitz Dec 08, 2012 

    I just downloaded Beta 3, but the download link is set to beta 2. So I copied and pasted the link address in to my address bar and changed the 2 into a 3 and then hit enter and beta 3 downloaded.

  • Jochem Dec 08, 2012 

    Saw the image of the Nexus 7 in my RSS feeds and was briefly excited that hardware decoding was somehow implemented. But I should’ve know better ;) .

  • purewitz Dec 08, 2012 
  • HenryFord Dec 08, 2012 

    @NineT9 There is no “Frodo” in “The Hobbit” ;)

  • thy91 Dec 08, 2012 

    Damn still not playimg properly on my tab 2 7″ but it is improving with each beta :-)

  • walt Dec 08, 2012 

    The beta 3 osx 64 bit package gives an error, package damaged

  • Darth.75 Dec 08, 2012 

    Downloaded android beta 3. First impression: works perfect on my Nexus 7. However, still some testing to do. Will try library mode first.

  • necrosis Dec 08, 2012 

    Are these still ignored if placed in advancedsettings.xml?

  • necrosis Dec 08, 2012 

    viewstates
    locale
    services
    skinsettings

    Keep frogetting anything in brackets gets deleted.

    Are these still ignored if placed in advancedsettings.xml?

  • marc Dec 08, 2012 

    i want support for a10 allwinner :( i have HACKBERRY :( is possible?

  • agreendc Dec 08, 2012 

    I installed beta 2 on my brand new out of the box nexus 7 and all i get are the ‘sorry xbmc has stopped working’.

    It works on my stock samsung gnex running android 4.1… but the video and audio are choppy to the point where its unwatchable.

  • yoda Dec 08, 2012 

    XBMC is truly amazing project! Thank you all.

  • The Eggman Dec 08, 2012 

    Same issues from 1st 12 beta..scrapes for thumbs are blank…fanart fine though..

  • renegade Dec 08, 2012 

    You guys rock. Thanks so much for all your hard work on this release, it is truly great and turns lots of things that were rough edges last year into shiny diamonds :-)

  • marianodt Dec 08, 2012 

    It works perfect in my N7 with Android 4.2.1. I´ve only tried movies and music but so far it looks great.
    Thanks! I hope to get the final version soon. :-)

  • natethomas Dec 08, 2012 

    @purewitz
    Yup, just a caching error. Hitting refresh on the download page should also fix it.

  • natethomas Dec 08, 2012 

    @walt
    Could you try downloading again? I downloaded it last night and having it running right now without issue.

  • Rocky Dec 08, 2012 

    There is a lot of AMLogic AML8726 based devices with Android becoming available from China these days.

    So any chance official XBMC for Android builds with AMLPlayer bundled from Team-XBMC will come soon?

  • Tom Dec 08, 2012 

    Still not working on Mele A2000(A10 Allwinners), XBMC stopped working

  • Stefan Dec 08, 2012 

    On my eb1012 (nvidia ion computer) Beta1 works flawlessly, but in both Beta2 and Beta3 when playing 720p .mkv’s there is no audio and the video stutters horribly. SD-videos work fine, with audio and no stuttering video.
    I’m gonna try a clean install and see if it helps.

  • Steven Dec 08, 2012 

    The best just keeps on getting better. Glad I moved over from MediaPortal :D

  • cjav Dec 08, 2012 

    Any reason why the PVR MythTV addon is not available in Android? Great to see XBMC working in my Galaxy Nexus Android 4.2.

  • Christopher Dec 08, 2012 

    Blu-Ray menu’s work under Mac OS X 10.8! Wahoooo!

  • Devin Dec 08, 2012 

    @Stefan
    I have the same problem. No sound and terrible video stutter.

  • Gerard Dec 08, 2012 

    Nice, but unfortunately this beta3 release breaks audio. The proposed fix (direct sound option) does not work for me. So it’s back to Eden again for a while…

  • Jason Dec 08, 2012 

    Anyone having stuttering/sound issues should check the sound settings and make sure the output matches what you have, I noticed mine changed from 5.1 to 7.0 and bad stuttering, changed back to 5.1, all gone.

  • Billyintexas Dec 09, 2012 

    What is PVR???

  • PizzaCat Dec 09, 2012 

    Disappointed, still have the small font issue, fixed by hitting enter at the very first screen after boot. No audio on my asrock 330 ion via hdmi, xbmcbuntu desktop still has small font issue.

  • PizzaCat Dec 09, 2012 

    Seems to get stuck during install updating file 37 of 109, why am I having to update 109 files for a brand new install?

  • PizzaCat Dec 09, 2012 

    Can not see what it is updating either having the large font makes the detail box too small to see anything in it, no way to resize either.

  • Stefan Dec 09, 2012 

    @Devin
    Worked fine after av clean install for me. And after adding my video library again, and syncing with traktr everything was perfect :-)

  • pilouccio Dec 09, 2012 

    Hi

    Works great on nexus 7

  • PizzaCat Dec 09, 2012 

    I stand corrected, I let the install complete completely, it took 2 hours to download additional stuff, I think thetvdb may be having issues as I keep getting a time out error, on my mac it is working fine oddly.

  • 3dfx Dec 09, 2012 

    Path substitution in beta3 (running on linux) is broken, worked fine in beta2, rolled back to beta2

  • STR Dec 09, 2012 

    Beta 3 is not stable – keeps crashing on Snow Leopard MBP. Horribly slow.

  • Sahrg Dec 09, 2012 

    XBMCbuntu is truly an amazing piece of software and I am a very happy user.
    If I were to suggest a thing it would be either a working guide to fixing (HDMI) sound in chromium when logged in to the windowmanager or preferably that it would work from the beginning.
    I do log in and use the desktop from time to time and would be very happy if the sound would be working.
    That said, so far the path with the new sound engine seems to be a major improvement, the lack of straight forward working audio have been the single biggest thing to create irritation in xbmc through every version so far…

    Other than that: I can just bring my hands together, stand up and clap them – Keep up the brilliant work and may XBMC continue to be the obvious mediacenter to choose.

  • mahanyc Dec 09, 2012 

    I really appreciate all the effort of the XBMC team and am amazed by the new features and enhancements since I first replaced my popcorn hour with an XBMC setup several years ago. I know it’s not final yet, but I am having trouble with livetv through mythtv – specifically whenever I stop a recording it freezes XBMC (windows 7 setup – mythtv running version 0.26 on mythbuntu) – just want to make sure that I am not the only one. Can’t wait to see what the future holds for XBMC.

  • subcell Dec 09, 2012 

    installed Beta 3 after a fresh Win7 and it’s almost perfect!

    Still got the True Full screen bug with 30 fps material…

    Great stuff!!

  • DefCon Dec 09, 2012 

    My 2 cents on Frodo beta 2 and Beta 3 is that Network and errorcontroll is much better then Eden where i have had stalls and freezes , with that said my showstoppers is stuttering video from avi’s, from tuxbox connection (dreambox 500) , from mediaportal client, so i rolled back to eden (margo-eden-pvr4) to get system to work and keep wife happy

  • Dams Dec 09, 2012 

    mythtv pvr addon not working with beta 3 (XBMC_MythTV_cmyth_win32.dll not included in installer)

  • Dams Dec 09, 2012 

    @Dams
    i forgot to mention i was running on windows

  • mahanyc Dec 09, 2012 

    @Dams
    You can install it yourself from a zip file located at http://www.dotnetdevelopers.net/XBMC/xbmcpvr.html – that’s what I did – however, I still have a situation where whenever I stop playback of a recording it locks up XBMC and I have to kill the program so it is not fully working yet

  • Kasun Dec 10, 2012 

    Installed Frodo Beta 2 on my AMD Fusion. It was fine for a day or two and it just froze while playing a video.

    Log shows “CDVDMessageQueue(audio)::Get – asked for new data packet, with nothing available” at the end.

  • RAffaeleDiana Dec 10, 2012 

    Hello.
    A lot of us are only asking one important thing. Hardware decoding for chipsets like rk3066 or galaxy s3 !!!! Thanks

  • Nas Dec 10, 2012 

    Still choppy on galaxy tab 2 7″. I suspect it will be fixed in future releases.

  • EricV Dec 10, 2012 

    XBMC on my acer A700 is working well although real TV HD streaming is still not OK. Annoying is the fact that tvheadend PVR addon cause it to fail to exit if tvheadend server is not up.

  • SynC Dec 10, 2012 

    @PizzaCat

    Same here.

  • Pop006 Dec 10, 2012 

    I checked the forms for maybe 20 mins and couldn’t find where to post bugs (maybe you guys could include a link or start a thread for each new beta, for noobs like me)… But in the Android Beta3 apk, you can not change the weather location or add a new one. At least not on my Nook Tablet. Everything else so far works fine, amazing job!

  • Anonymous Dec 10, 2012 

    Changed mine to WASPI in audio settings now working fine@Stefan

  • Stephen Dec 10, 2012 

    This is looking good on my Win 7 PC and my Nexus 7. Astounding stuff!

    I’m tempted now to start looking at getting some Freeview tuners (I’m in the UK) and try out the PVR functionality. Can anyone recommend any? I’d like to do this on a reasonably tight budget if that’s possible. They’d have to be external (USB?) tuners as my PC is a Revo R3700 nettop.

  • Zeke Dec 10, 2012 

    As great as the second and third betas are, what really stops me transitioning to them is a lot of things I rely on (TVCatchup plugin, PM3.HD skin, few other things) were broken shortly after the October 5th alpha I’m using now… in fact with the alpha itself 4oD and Demand5 are broken but as I don’t use these it’s not a big deal. Because XBMC is such a collaborative freeware effort the people who develop things for it often are not told when changes in the core break their addons or skins and I think this should be looked at as part of the development process, because as nice as it is adding bells and whistles if it breaks pre-existing features that people rely on XBMC for it’s not worth the effort for them. Although if everyone catches up to the changes on or before release of Frodo stable none of that matters, assuming Frodo stable itself doesn’t have big unfixed bugs that everyone missed like the messed up video playlist order one that drove me nuts in Eden stable.

    Sorry if this seems grouchy or moany, it’s just that although I don’t code I have always been very good at looking at things in a detailed overview sort of way, and my main observation seems to be “fix and/or improve existing features, be more conservative adding new features, provide better backward compatibility with older versions” and things like that. XBMC is still light years ahead of most of the competition so making it more reliable (on my Win32 Acer Revo machine XBMC crashes all the time, so much so I’ve had to map a kill/reload function to a button on my universal remote using EventGhost, plus there are numerous Android reports of being unusable to name just two examples) and far more stable should be more important than going too far too fast with such a complex piece of software being managed by a comparatively small team.

    Having said all that, I hope a lot of the problems we’re all experiencing are “opening night jitters” and I’m confident that Frodo is going in the right direction – it already looks like a massive leap from Eden and fixes a lot of issues I had with that, so when all the skins/addons are updated to match the new way of doing things it should be the best one ever!

  • C Dec 10, 2012 

    You have to un-mute it in alsamixer. I always had to do that. Works awesome on HDMI
    @PizzaCat

  • Shin Dec 10, 2012 

    @RAffaeleDiana
    Works on my galaxy note 2 which is close to the s3.

    Stylus, screen auto rotate and HDMI still don’t work tough.

  • Danny3 Dec 10, 2012 

    Hi guys,

    I’m the one who made the translation for Romanian language for the last 2 releases.
    Sorry for not updating the translation since last year, I was busy with something else :( .
    Now I have time and I’m glad to help again. I sent a request to join the team on Transifex.

    Thank you!

  • drmacmuffin Dec 10, 2012 

    Android:
    Live-TV works on zenithink zt282 @ ICS 4.0.3
    still missing Bonjour, someone gonna implement jmDNS for final?

  • nedscott Dec 10, 2012 

    @Zeke

    We have an add-on developers mailing list that any add-on authors can subscribe to in order to get such notices. We always strive for backwards compatibility when it’s reasonable/possible.

  • Tomasz Dec 11, 2012 

    little issue, when i explore my video or music library in Frodo beta 3 he suddenly stop working and exit to windows.

  • Memphiz Dec 11, 2012 

    @drmacmuffin
    No way. We had already poked at zeroconf and it was a nogo atm. This won’t be available in frodo on android.

  • Darth.75 Dec 11, 2012 

    @agreendc

    You need beta 3

  • JiSiN Dec 11, 2012 

    Well done… really looking forward for the Frodo Final Release :)

  • JiSiN Dec 11, 2012 

    LoL just finished downloading Beta3 and a few minutes later i just recognized now we get RC1 :)
    http://mirrors.xbmc.org/releases/

  • Anonymous Dec 11, 2012 

    hey, just updated my libraries and did an install. I got RC1! Is beta 3 already old news?

  • spoonTRex Dec 12, 2012 

    How does one change the skin settings to Confluence in this beta? I haven’t tried the other ones, but my options in System have disappeared.

  • spoonTRex Dec 12, 2012 

    @spoonTRex
    Nevermind. The moment I finally post a comment, I find the info I need: http://wiki.xbmc.org/index.php?title=Add-on:Confluence/Settings

  • Robert Dec 12, 2012 

    @Stefan
    Same problem since beta 2 with the stottering video HD files. I use an Asrock ION 330…

  • Robert Dec 12, 2012 

    Forgot to mention I use WIndows 7.

  • Robert Dec 12, 2012 

    I did some more testing and there definitly something wrong with HD playback on ION 330 on windows.
    For testing I use a 1080p clip that always played well until beta 2 (It’s still OK on beta 1). The playback is stuttering around 4 fps, like there is no hardware decoding enabled.

    If I can help with an bug report or logfile please let me know.

  • Eat Dec 12, 2012 

    We shouldn’t expect hardware acceleration/decoding anytime soon for android right ? Interesting that programs like mxplayer can yet not this. I’ll be sticking with mxplayer until a proper release is out thanks

  • monkeysweat Dec 12, 2012 

    is it just me or are all the video and music sources not visible in the ‘files’ section,, I only see the removeable usb drives in the files section.. but none of my hard drive folders,, it does keep updating correctly, but I do need to go in there to ‘refresh’ and manually get some folders to pull correct information from internet but I can’t at the moment…

  • JaRuBe Dec 12, 2012 

    since I installed RC1, the subtitle downloader doesn’t work anymore. Anyone alse having this issue?

  • nedscott Dec 12, 2012 

    @Eat
    Unlikely that XBMC for Android will have any kind of universal hardware decoding for v12. Other players have hardware decoding because they signed NDAs or are using closed source code, which are not options for XBMC.

  • nedscott Dec 12, 2012 

    @Robert
    Most likely it is an issue with audio settings.

  • Minsc&Boo Dec 13, 2012 

    Frodo beta 1 and Frodo beta 2 work.

    Frodo beta 3 and Frodo RC1, not only crash windows but completely freeze my PC. green bars fill the screen and everything stops. Only a restart can fix it.

    INTEL.SSD_Win7.64bit_ATI6870.2GB_Intel.Q9450_AUZEN.PRELUDE7.1

    Frodo beta 1, 2, 3, RC1 installed in separate folders.

  • arad85 Dec 18, 2012 

    @Robert

    Check your video settings and that deinterlacer isn’t set to forced on. I had that problem with a previous version – the Ion isn’t powerful enough to do it and it will attempt to deinterlace even progressive video if told to.

  • robert Dec 19, 2012 

    @nedscott
    i don’t think it’s an audio issue. I have analog audio set up; which worked in beta 1 and many nightly builds before.

  • Zeke Dec 19, 2012 

    arad85 :
    @Robert
    Check your video settings and that deinterlacer isn’t set to forced on. I had that problem with a previous version – the Ion isn’t powerful enough to do it and it will attempt to deinterlace even progressive video if told to.

    Ion 330 is powerful enough to deinterlace, it’s really not an issue on my Revo R3610. I have it interlacing off by default and set it to on when watching 1080i TS files (H.264/AC3) from my Freesat box, and it deinterlaces to a nice steady 50fps with no issue whatsoever.

  • Hanwer Dec 19, 2012 

    Hola,habria alguna posibilidad de instalarse en un webtv lite o si en algun momento hareis uno para este aparato,un saludo

  • nedscott Dec 20, 2012 

    robert :

    @nedscott
    i don’t think it’s an audio issue. I have analog audio set up; which worked in beta 1 and many nightly builds before.

    A lot of audio tweaking has been going on, and it’s very possible that XBMC is trying to keep the video in sync with the audio. So if audio is slowing down/messing up for some reason, it can cause issues for video as well. It could be something else, though.

About XBMC

XBMC is a free and open source media player application developed by the XBMC Foundation, a non-profit technology consortium. XBMC is available for multiple operating-systems and hardware platforms, featuring a 10-foot user interface for use with televisions and remote controls. It allows users to play and view most videos, music, podcasts, and other digital media files from local and network storage media and the internet.